つうさにメモブログ

つうさにがメモをブログとして書いていくところ

quelpa emacs26.1 謎のエラー

emacsわからん...

htmlizeをインストールしたかった

orgのhtmlエクスポートでhtmlizeが必要だよーって言われたからいつものように、

;;; htmlize
(use-package htmlize :quelpa t
  :defer t)

を記述して評価したらエラーを吐かれた。Wrong type argument: arrayp, nilというエラー。

M-x quelpahtmlizeを選んで実行しても同様。バックトレース見てもよくわからない。

emacs-26.1-z-mac-7.3を使っていたが、バージョンを下げてemacs-25.3-mac-6.8にしたらエラー吐かれずインストールできた。orgのhtmlエクスポートもうまくいった。

謎...

追記

.emacs.dを消して、同じinit.elで全部のパッケージ再インストールしたらemacs-26.1-z-mac-7.3でもエラーは起こらなかった。うーむ何が原因だったのかわからんですね。多分quelpa.elc(バイトコード)あたりが怪しかったんでしょう。